Phone Service Disruption
Incident Report for Cardknox
Resolved
The issue affecting our phone system has been resolved. It was determined to be caused by an external carrier outage. All systems are operational.
Posted Nov 09, 2022 - 10:29 EST
Investigating
We are aware of an issue with our phone service preventing some callers from reaching us. We are investigating and will update this page as more information becomes available.
Posted Nov 09, 2022 - 10:02 EST