Transaction Processing Issues
Incident Report for Cardknox
Resolved
Elevon confirmed that this was an issue with the Debit networks. Approvals are back at normal levels. This incident is now considered resolved.
Posted Oct 23, 2021 - 21:19 EDT
Investigating
We are receiving reports of debit transactions failing and/or lengthy transaction processing times. We are investigating and will update as more information becomes available.
Posted Oct 23, 2021 - 17:20 EDT
This incident affected: Partners (Elavon).