Profit Stars (ACH) Processing Interruption
Incident Report for Cardknox
Resolved
This incident has been resolved.
Posted Jun 03, 2024 - 09:53 EDT
Identified
Profit Stars has notified us that they are currently experiencing intermittent connectivity issues which is affecting ACH processing. We will update as more information becomes available.
Posted Jun 02, 2024 - 10:54 EDT
This incident affected: Partners (ACH Services).