Transaction Processing Issues - Elavon
Incident Report for Cardknox
Resolved
Elavon has resolved the issue and transactions have returned to normal approval levels. This incident is now considered resolved.
Posted Dec 28, 2020 - 21:44 EST
Identified
We are receiving reports of transactions failing and/or lengthy transaction processing times on the Elavon platform. Elavon has confirmed that they are aware of the issue and they are working on resolving it. We will update this page as more information becomes available.
Posted Dec 28, 2020 - 18:59 EST
This incident affected: Cardknox Services (Transaction Processing) and Partners (Elavon).