Fidelipay Portal
Incident Report for Cardknox
Resolved
We have identified and resolved the issue. This incident is now considered closed.
Posted Apr 28, 2021 - 13:37 EDT
Investigating
We are receiving reports of issues accessing secure.fidelipay.com. We are investigating and will provide updates as they become available.
Posted Apr 28, 2021 - 13:30 EDT
This incident affected: Cardknox Services (Merchant Portal).