ACH Transaction Processing Issues
Incident Report for Cardknox
Resolved
ProfitStars has notified us that they have resolved the issue. This incident is now closed.
Posted Apr 09, 2021 - 17:04 EDT
Identified
ProfitStars has notified us that they are experiencing technical issues which are affecting ACH transactions processing. We will update here as more information becomes available.
Posted Apr 09, 2021 - 09:36 EDT
This incident affected: Partners (ProfitStars).