Pax Terminals Connect Error

Incident Report for Cardknox

Identified

Sola and Pax have identified the issue with some Pax devices. Pax has implemented a fix and they have rolled out an update to the to the affected devices. If your device is still not operating normally, please reboot it and try a transaction. If it still is not working, please contact Sola's technical support team to get the your device manually updated.
Support Phone: 844-227-3566
Support Email: techsupport@fidelitypayment.com
Posted Apr 14, 2025 - 15:15 EDT

Update

We are continuing to monitor for any further issues.
Posted Apr 14, 2025 - 09:45 EDT

Monitoring

Sola and Pax have identified the issue with the affected Android Pax devices. Pax has implemented a fix and they in the process of rolling out an update to the affected devices. If your device did not update or if it was offline, please bring it online. If it does not update, please reboot the device and it should download the update. If your device is still not operating normally or it did not automatically update, please contact Sola's technical support team to get the your device manually updated.
Posted Apr 14, 2025 - 08:30 EDT

Identified

Sola and Pax have identified the issue with the affected Android Pax devices. Pax has implemented a fix and they are in the process of rolling out an update to the to the affected devices. If your device is still not operating normally, please contact Sola's technical support team to get the your device manually updated.
Posted Apr 14, 2025 - 07:47 EDT

Investigating

We are currently investigating an issue where some merchants are experiencing a "Connect Error" when trying to process using some Pax devices. Our teams are currently investigating and we will post updates as soon as they become available.
Posted Apr 12, 2025 - 10:50 EDT
This incident affects: Cardknox Services (Transaction Processing).