Fidelipay.com DNS issues
Incident Report for Cardknox
Resolved
This incident has been resolved.
Posted Apr 17, 2024 - 13:23 EDT
Investigating
We are investigating an issue that is preventing users from accessing the Fidelipay Portal (secure.fidelipay.com) as well as API transactions being processed via fidelipay.com endpoints. We are urgently working on resolving this issue. Until service is restored, users can access their Fidelipay Portal by navigating to https://secure.usaepay.com/login and logging in with their Fidelipay credentials.
Posted Apr 17, 2024 - 10:22 EDT
This incident affected: Partners (USAePay).