Amex Transaction Processing Issues
Incident Report for Cardknox
Resolved
AMEX has confirmed that transaction approval levels are back to normal. This incident is now resolved.
Posted Jun 17, 2021 - 17:34 EDT
Investigating
We are receiving reports of Amex transactions failing and/or lengthy transaction processing times. This appears to be an issue with Amex's systems, however we are investigating and will update as more information becomes available.
Posted Jun 17, 2021 - 15:38 EDT
This incident affected: Cardknox Services (Transaction Processing) and Partners (American Express).