EBT Transaction Processing Issuess
Incident Report for Cardknox
Resolved
Transactions are now processing at normal approval levels. This is incident is now considered resolved.
Posted Feb 19, 2024 - 16:14 EST
Investigating
We are receiving reports of processing errors on EBT transactions. We will update as more information becomes available.
Posted Feb 19, 2024 - 15:24 EST
This incident affected: Partners (EBT).