Canadian Debit Transaction Processing Issues

Incident Report for Cardknox

Resolved

This issue has been resolved
Posted May 21, 2022 - 20:19 EDT

Identified

Elavon has identified issues on the debit network and their technical teams are engaged and working towards resolution
Posted May 21, 2022 - 14:02 EDT

Investigating

We are receiving reports of debit transactions failing and/or lengthy transaction processing times for Canadian merchants.. We are investigating and will update as more information becomes available.
Posted May 21, 2022 - 13:51 EDT
This incident affected: Partners (Elavon).