ProfitStars ACH Transaction Processing Issues
Incident Report for Cardknox
Resolved
ProfitStars has advised that they have resolved the issue. This incident is now closed.
Posted Sep 05, 2023 - 19:31 EDT
Identified
ProfitStars has confirmed that they are experiencing technical issues that are causing intermittent transaction failures. Their technical teams are actively working on resolving the issues.
Posted Sep 05, 2023 - 18:32 EDT
Investigating
We are receiving reports of ACH transactions failing on the ProfitStars platform. We will update as more information becomes available.
Posted Sep 05, 2023 - 18:24 EDT
This incident affected: Cardknox Services (Transaction Processing) and Partners (ACH Services, ProfitStars).