ProfitStars ACH Transaction Processing Issues
Incident Report for Cardknox
Resolved
This incident has been resolved.
Posted Sep 10, 2023 - 10:10 EDT
Investigating
We are receiving reports of ACH transactions failing on the ProfitStars platform. We will update as more information becomes available.
Posted Sep 10, 2023 - 00:06 EDT
This incident affected: Partners (ProfitStars).