Elavon/Converge Service Degradation
Incident Report for Cardknox
Resolved
Elavon has advised that they have resolved the issue.
Posted Oct 08, 2024 - 15:29 EDT
Investigating
Elavon is currently experiencing a service degradation affecting Converge transaction processing. They are aware of the issue and are working on a resolution.
Posted Oct 08, 2024 - 14:32 EDT
This incident affected: Partners (Elavon).