Transaction Processing Issues - Elavon
Incident Report for Cardknox
Resolved
Elavon has notified us the issue has been resolved. This incident is now closed.
Posted Jun 03, 2021 - 14:48 EDT
Identified
Elavon has advised that this issue is affecting a small subset of their merchants. They have identified the issue and are working on resolving.
Posted Jun 03, 2021 - 14:06 EDT
Investigating
We are receiving reports of transactions failing and/or lengthy transaction processing times on the Elavon platform. We are investigating and will update as more information becomes available.
Posted Jun 03, 2021 - 11:48 EDT
This incident affected: Cardknox Services (Transaction Processing) and Partners (Elavon).