FISERV (First Data) OMAHA Amex Transaction Processing Issues
Incident Report for Cardknox
Resolved
Transaction approvals on Amex transactions are back to normal approval levels. This incident is now considered resolved.
Posted Nov 10, 2019 - 15:36 EST
Identified
We are receiving reports of transactions failing and/or lengthy transaction processing times on the FISERV (First Data) OMAHA platform affecting Amex transactions. We will update as more information becomes available to us.
Posted Nov 10, 2019 - 14:32 EST
This incident affected: Cardknox Services (Transaction Processing) and Partners (FISERV (First Data) Omaha).